summaryrefslogtreecommitdiff
path: root/dev-java/jortho/jortho-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jortho/jortho-1.0.ebuild')
-rw-r--r--dev-java/jortho/jortho-1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jortho/jortho-1.0.ebuild b/dev-java/jortho/jortho-1.0.ebuild
new file mode 100644
index 000000000000..f8d16101d570
--- /dev/null
+++ b/dev-java/jortho/jortho-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java spell-checking library"
+HOMEPAGE="https://www.inetsoftware.de/other-products/jortho"
+SRC_URI="mirror://sourceforge/project/jortho/JOrtho%20Library/${PV}/JOrtho_${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+java_prepare() {
+ find . -name '*.jar' -exec rm -v {} + || die
+}
+
+JAVA_SRC_DIR="src/com"
+src_compile() {
+ mkdir -p target/classes/com/inet/jortho/i18n || die
+ find src -name '*.properties' \
+ -exec cp {} target/classes/com/inet/jortho/i18n \; || die
+
+ java-pkg-simple_src_compile
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ use examples && java-pkg_doexamples src/SampleAppl{et,ication}.java
+}