summaryrefslogtreecommitdiff
path: root/dev-java/java-config/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/java-config/files')
-rw-r--r--dev-java/java-config/files/java-config-2.2.0-prefix.patch15
-rw-r--r--dev-java/java-config/files/java-config-2.2.0-py38.patch52
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-java/java-config/files/java-config-2.2.0-prefix.patch b/dev-java/java-config/files/java-config-2.2.0-prefix.patch
deleted file mode 100644
index 068538a69f91..000000000000
--- a/dev-java/java-config/files/java-config-2.2.0-prefix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Wait for the java team to upstream this patch.
-Bug: 591156
---- /setup.py 2013-02-15 07:12:09.000000000 +0900
-+++ /setup.py.new 2016-08-13 16:38:22.000000000 +0900
-@@ -87,8 +87,8 @@
- elif arch in ['hpux']:
- defaults = '*= hp-jdk-bin'
-
-- os.mkdir(self.root + '/usr/share/java-config-2/config/')
-- with open(self.root + '/usr/share/java-config-2/config/jdk-defaults.conf', 'w') as f:
-+ os.mkdir(self.root + eprefix + '/usr/share/java-config-2/config/')
-+ with open(self.root + eprefix + '/usr/share/java-config-2/config/jdk-defaults.conf', 'w') as f:
- f.write("# This files contain the default support jdk's\n")
- f.write(defaults + "\n")
-
diff --git a/dev-java/java-config/files/java-config-2.2.0-py38.patch b/dev-java/java-config/files/java-config-2.2.0-py38.patch
deleted file mode 100644
index cb59e1f36be1..000000000000
--- a/dev-java/java-config/files/java-config-2.2.0-py38.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 5e7cc49184e657bd446998f4b08e9106e5215ce5 Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Thu, 7 May 2020 02:45:57 -0700
-Subject: [PATCH] replace is with ==
-
----
- src/java-config-2 | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/java-config-2 b/src/java-config-2
-index 8ad2539..84ecd30 100755
---- a/src/java-config-2
-+++ b/src/java-config-2
-@@ -199,7 +199,7 @@ def set_user_vm(option, opt, value, parser):
- if not vm:
- fatalError("Could not find a vm matching: %s" % value)
- else:
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- fatalError("The user 'root' should always use the System VM")
- else:
- try:
-@@ -227,7 +227,7 @@ def user_classpath_target():
- # Deprecated
- def set_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- pkgs = value.split(',')
- manager.set_classpath(system_classpath_target(), pkgs)
-
-@@ -252,7 +252,7 @@ def set_user_classpath(option, opt, value, parser):
- # Deprecated
- def append_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- pkgs = value.split(',')
- manager.append_classpath(system_classpath_target(), pkgs)
-
-@@ -277,7 +277,7 @@ def append_user_classpath(option, opt, value, parser):
- # Deprecated
- def clean_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- manager.clean_classpath(system_classpath_target())
- update_env()
- else:
---
-2.26.2
-