summaryrefslogtreecommitdiff
path: root/dev-java/htmlparser/htmlparser-1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/htmlparser/htmlparser-1.4-r1.ebuild')
-rw-r--r--dev-java/htmlparser/htmlparser-1.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/htmlparser/htmlparser-1.4-r1.ebuild b/dev-java/htmlparser/htmlparser-1.4-r1.ebuild
new file mode 100644
index 000000000000..f1d565a5e400
--- /dev/null
+++ b/dev-java/htmlparser/htmlparser-1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementation of the HTML5 parsing algorithm in Java"
+HOMEPAGE="http://about.validator.nu/htmlparser/"
+SRC_URI="http://about.validator.nu/${PN}/${P}.zip"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="
+ dev-java/icu4j:52
+ dev-java/jchardet:0
+ dev-java/xom:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+java_prepare() {
+ java-pkg_clean
+ mkdir -p build lib || die
+ cp "${FILESDIR}/build.xml" build.xml || die "cp failed"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="icu4j-52,xom,jchardet"
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ use source && java-pkg_dosrc src/*
+ use doc && java-pkg_dojavadoc docs
+}