summaryrefslogtreecommitdiff
path: root/dev-java/hawtjni-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/hawtjni-runtime')
-rw-r--r--dev-java/hawtjni-runtime/Manifest2
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/Manifest b/dev-java/hawtjni-runtime/Manifest
index a0f39ecb1691..12b35469c700 100644
--- a/dev-java/hawtjni-runtime/Manifest
+++ b/dev-java/hawtjni-runtime/Manifest
@@ -1,3 +1,5 @@
DIST hawtjni-project-1.15.tar.gz 1606236 BLAKE2B 52357dbefde43ec82cf218ada90642d118ebaa6a6be173cc1f4f48377fda95b902f0a90dfb60822c02c144b9bf13d0800c94d67cc2f9c76e607bbbb80a80898e SHA512 1a93658bf8621c770cf97b546c6a5c0cf1821b06cb16dbc872ad0c830c599d3947ffe56b4cca16217a510d4e929ebcfc5eabdf4ad4364f5225b53d22c7d48abb
+DIST hawtjni-project-1.18.tar.gz 1615093 BLAKE2B a195bcfb7c213ec4451605f62a1ab3546b7fa160a03d8c6c1a77a58e103481a196845d924d9f1a08cc2a17dfd71f9428f69a64983df00333cc00435c7dde2e5d SHA512 beeacd92c9b4fef413cb2d339041042ffd79fe7cb62c4fa3bcc8c2d758402183a5806ebd0ee91754f9f0025f4115022c71705e8f6330f2fa8b8cead774a30bf0
EBUILD hawtjni-runtime-1.15-r1.ebuild 703 BLAKE2B c662a823448e0d7c5c6c3d24c79fb33b2b3728a97fe2ec35cb315adb5919768a14b28e89f035d8ceeba67ceda82829589131dda295b65c6859700b0b9904e6dd SHA512 e587fbd563d1e0b6594159f0bd2ae0b367c323d94dfa625c74e54c20f2246601a0dd3beebd11cbc98e698c9fc6646d1248600707fe278f8fa6e619ff924f7c56
+EBUILD hawtjni-runtime-1.18.ebuild 727 BLAKE2B 05d284d9d8ab3f99b6ddd25807828512e473943302c5642c767ffbde95043efc3b8c77ffca01d5a3dcd6f23c99db87e14e865f7647a832be6d39e873325c6b93 SHA512 8a194c6d560d9458bef79523a71093c79fe948f93c428b3908188262a106efca0ec6918a218fbb103e7d9c409456072d209f3ab2728e3ed5dd49ed3199114b1d
MISC metadata.xml 330 BLAKE2B b1ee35557d02e8ace5e3d19dd0787435f4af0e9799f365258104e1bb81d4406f8ed71499d99e732418fe892036da27143c99b2507ca8e6830f0ae9fbbe51bf25 SHA512 ca78466efcd02b05bcfdaf99b327fec70f13f0a1e2f646f4418799021c946b51d9dc09c303e95d63d074677a52803ac667e37097f1dd241a8cf14c3f49b663c9
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
new file mode 100644
index 000000000000..13748884cb64
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID=""
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/hawtjni-project-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,notice,readme}.md )
+
+S="${WORKDIR}/hawtjni-hawtjni-project-${PV}"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.fusesource.hawtjni.runtime"
+JAVA_SRC_DIR="${PN}/src/main/java"