summaryrefslogtreecommitdiff
path: root/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild')
-rw-r--r--dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild
deleted file mode 100644
index a193aa43cf2d..000000000000
--- a/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 eutils
-
-DESCRIPTION="GNU Crypto cryptographic primitives for Java"
-HOMEPAGE="https://www.gnu.org/software/gnu-crypto/"
-SRC_URI="ftp://ftp.gnupg.org/GnuPG/gnu-crypto/gnu-crypto-2.0.1.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.3"
-RDEPEND=">=virtual/jre-1.3"
-
-RESTRICT="test"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-jdk15.patch"
-}
-
-src_configure() {
- # jikes support disabled, doesnt work: #86655
- econf JAVAC="javac" JAVACFLAGS="$(java-pkg_javac-args)" --with-jce=yes --with-sasl=yes
-}
-
-src_compile() {
- emake -j1
- if use doc ; then
- emake -j1 javadoc
- fi
-}
-
-src_install() {
- einstall
- rm "${ED}"/usr/share/*.jar
-
- java-pkg_dojar source/gnu-crypto.jar
- java-pkg_dojar jce/javax-crypto.jar
- java-pkg_dojar security/javax-security.jar
-
- use doc && java-pkg_dojavadoc api
- use source && java-pkg_dosrc source/* jce/* security/*
-
- dodoc AUTHORS ChangeLog NEWS README THANKS
-}