summaryrefslogtreecommitdiff
path: root/dev-java/antlr/antlr-2.7.7-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/antlr/antlr-2.7.7-r8.ebuild')
-rw-r--r--dev-java/antlr/antlr-2.7.7-r8.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-java/antlr/antlr-2.7.7-r8.ebuild b/dev-java/antlr/antlr-2.7.7-r8.ebuild
deleted file mode 100644
index 10056965f258..000000000000
--- a/dev-java/antlr/antlr-2.7.7-r8.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A parser generator for many languages"
-HOMEPAGE="http://www.antlr2.org/"
-SRC_URI="http://www.antlr2.org/download/${P}.tar.gz"
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6"
-
-S="${WORKDIR}/${P}"
-
-JAVA_SRC_DIR="${S}/${PN}"
-
-DOCS=( CHANGES.txt README.txt )
-
-src_prepare() {
- default
- java-pkg_clean
-
- # Delete build files from examples.
- find examples \( -name Makefile.in -o -name shiplist \) -delete || die
-}
-
-# Avoid configure script.
-src_configure() { :; }
-
-src_install() {
- java-pkg-simple_src_install
- java-pkg_dolauncher antlr --main antlr.Tool
-
- use doc && java-pkg_dohtml -r doc/*
- use examples && java-pkg_doexamples examples/java
- use source && java-pkg_dosrc antlr
-
- einstalldocs
-}