summaryrefslogtreecommitdiff
path: root/dev-haskell/zlib/zlib-0.6.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/zlib/zlib-0.6.1.1.ebuild')
-rw-r--r--dev-haskell/zlib/zlib-0.6.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/zlib/zlib-0.6.1.1.ebuild b/dev-haskell/zlib/zlib-0.6.1.1.ebuild
new file mode 100644
index 000000000000..ffac01f1ec30
--- /dev/null
+++ b/dev-haskell/zlib/zlib-0.6.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compression and decompression in the gzip and zlib formats"
+HOMEPAGE="http://hackage.haskell.org/package/zlib"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RESTRICT=test # needs porting to new test tools
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"