summaryrefslogtreecommitdiff
path: root/dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild')
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild
new file mode 100644
index 000000000000..61d2974e36fa
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="https://github.com/snoyberg/xml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"