summaryrefslogtreecommitdiff
path: root/dev-haskell/wxcore/wxcore-0.92.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wxcore/wxcore-0.92.2.0.ebuild')
-rw-r--r--dev-haskell/wxcore/wxcore-0.92.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/wxcore/wxcore-0.92.2.0.ebuild b/dev-haskell/wxcore/wxcore-0.92.2.0.ebuild
new file mode 100644
index 000000000000..4d6dfce86822
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.92.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+WX_GTK_VER="3.0"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal wxwidgets
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="https://wiki.haskell.org/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxc-0.92:${WX_GTK_VER}=[profile?]
+ >=dev-haskell/wxdirect-0.91:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}