summaryrefslogtreecommitdiff
path: root/dev-haskell/warp/warp-3.3.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/warp/warp-3.3.13.ebuild')
-rw-r--r--dev-haskell/warp/warp-3.3.13.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/warp/warp-3.3.13.ebuild b/dev-haskell/warp/warp-3.3.13.ebuild
new file mode 100644
index 000000000000..f9433e28e4b5
--- /dev/null
+++ b/dev-haskell/warp/warp-3.3.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -network-bytestring
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A fast, light-weight web server for WAI applications"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+allow-sendfilefd warp-debug"
+
+RESTRICT=test # requires network
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/auto-update-0.1.3:=[profile?] <dev-haskell/auto-update-0.2:=[profile?]
+ <dev-haskell/bsb-http-chunked-0.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.12:=[profile?]
+ >=dev-haskell/http2-2.0:=[profile?] <dev-haskell/http2-2.1:=[profile?]
+ >=dev-haskell/iproute-1.3.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.10:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/time-manager:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ >=dev-haskell/vault-0.3:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ dev-haskell/word8:=[profile?]
+ dev-haskell/x509:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/http-client
+ dev-haskell/hunit
+ >=dev-haskell/lifted-base-0.1
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag allow-sendfilefd allow-sendfilefd) \
+ --flag=-network-bytestring \
+ $(cabal_flag warp-debug warp-debug)
+}