summaryrefslogtreecommitdiff
path: root/dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild')
-rw-r--r--dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild b/dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild
deleted file mode 100644
index 202abac8b902..000000000000
--- a/dev-haskell/vector-builder/vector-builder-0.3.8.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.1.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-CABAL_HACKAGE_REVISION="1"
-inherit haskell-cabal
-
-CABAL_FILE="${S}/${PN}.cabal"
-CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
-
-DESCRIPTION="Vector builder"
-HOMEPAGE="https://github.com/nikita-volkov/vector-builder"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
- -> ${CABAL_DISTFILE}"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-RDEPEND=">=dev-haskell/vector-0.12:=[profile?] <dev-haskell/vector-0.13:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- test? ( >=dev-haskell/attoparsec-0.13 <dev-haskell/attoparsec-0.15
- >=dev-haskell/quickcheck-2.8.1 <dev-haskell/quickcheck-3
- >=dev-haskell/quickcheck-instances-0.3.11 <dev-haskell/quickcheck-instances-0.4
- <dev-haskell/rerebase-2
- >=dev-haskell/tasty-0.12 <dev-haskell/tasty-2
- >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
- >=dev-haskell/tasty-quickcheck-0.9 <dev-haskell/tasty-quickcheck-0.11 )
-"
-BDEPEND="app-text/dos2unix"
-
-src_prepare() {
- # pull revised cabal from upstream
- cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
-
- # Convert to unix line endings
- dos2unix "${CABAL_FILE}" || die
-
- # Apply patches *after* pulling the revised cabal
- default
-}