summaryrefslogtreecommitdiff
path: root/dev-haskell/text/text-1.1.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/text/text-1.1.1.3.ebuild')
-rw-r--r--dev-haskell/text/text-1.1.1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.1.1.3.ebuild b/dev-haskell/text/text-1.1.1.3.ebuild
new file mode 100644
index 000000000000..5aa1c86f2f19
--- /dev/null
+++ b/dev-haskell/text/text-1.1.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+RESTRICT="test" # quickcheck-2.7 is missing keywords due to new tf-random dep
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+# test? ( >=dev-haskell/hunit-1.2
+# >=dev-haskell/quickcheck-2.7
+# dev-haskell/random
+# >=dev-haskell/test-framework-0.4
+# >=dev-haskell/test-framework-hunit-0.2
+# >=dev-haskell/test-framework-quickcheck2-0.2 )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-deepseq-1.4.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}