summaryrefslogtreecommitdiff
path: root/dev-haskell/text-metrics/text-metrics-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/text-metrics/text-metrics-0.2.0.ebuild')
-rw-r--r--dev-haskell/text-metrics/text-metrics-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/text-metrics/text-metrics-0.2.0.ebuild b/dev-haskell/text-metrics/text-metrics-0.2.0.ebuild
new file mode 100644
index 000000000000..0e6d539734e3
--- /dev/null
+++ b/dev-haskell/text-metrics/text-metrics-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Calculate various string metrics efficiently"
+HOMEPAGE="https://github.com/mrkkrp/text-metrics"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-2:=[profile?]
+ >=dev-haskell/text-0.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0
+ >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-3.0 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}