summaryrefslogtreecommitdiff
path: root/dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild')
-rw-r--r--dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild b/dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild
new file mode 100644
index 000000000000..bf5b78a0a239
--- /dev/null
+++ b/dev-haskell/test-framework-hunit/test-framework-hunit-0.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HUnit support for the test-framework package"
+HOMEPAGE="https://batterseapower.github.com/test-framework/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+HASKELLDEPS=">=dev-haskell/hunit-1.2[profile?]
+ >=dev-haskell/test-framework-0.2.0[profile?]"
+RDEPEND=">=dev-lang/ghc-6.10
+ ${HASKELLDEPS}"
+DEPEND=">=dev-haskell/cabal-1.2.3
+ ${RDEPEND}"