summaryrefslogtreecommitdiff
path: root/dev-haskell/tar/tar-0.5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tar/tar-0.5.1.0.ebuild')
-rw-r--r--dev-haskell/tar/tar-0.5.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/tar/tar-0.5.1.0.ebuild b/dev-haskell/tar/tar-0.5.1.0.ebuild
new file mode 100644
index 000000000000..1937fea5f724
--- /dev/null
+++ b/dev-haskell/tar/tar-0.5.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Reading, writing and manipulating '.tar' archive files"
+HOMEPAGE="http://hackage.haskell.org/package/tar"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+#gienah: tests pass for me with QC-2.10.1
+#RESTRICT=test # QC-2.10 manages to generate counterexamples
+
+RDEPEND=">=dev-haskell/bytestring-builder-0.10.4.0.2:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/bytestring-handle
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'tasty >= 0.10 && <0.12' 'tasty >= 0.10' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8'
+}