summaryrefslogtreecommitdiff
path: root/dev-haskell/store/store-0.7.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/store/store-0.7.6.ebuild')
-rw-r--r--dev-haskell/store/store-0.7.6.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-haskell/store/store-0.7.6.ebuild b/dev-haskell/store/store-0.7.6.ebuild
deleted file mode 100644
index 515d0443bfc7..000000000000
--- a/dev-haskell/store/store-0.7.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6
-#hackport: flags: -small-bench,-comparison-bench
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast binary serialization"
-HOMEPAGE="https://github.com/fpco/store#readme"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # fails to build with newer smallcheck
-
-RDEPEND=">=dev-haskell/async-2.0.2:=[profile?]
- >=dev-haskell/base-orphans-0.4.3:=[profile?]
- >=dev-haskell/base64-bytestring-0.1.1:=[profile?]
- >=dev-haskell/bifunctors-4.0:=[profile?]
- >=dev-haskell/contravariant-1.3:=[profile?]
- >=dev-haskell/cryptohash-0.11.6:=[profile?]
- >=dev-haskell/fail-4.9:=[profile?]
- >=dev-haskell/free-4.11:=[profile?]
- >=dev-haskell/hashable-1.2.3.1:=[profile?]
- >=dev-haskell/hspec-2.1.2:=[profile?]
- >=dev-haskell/hspec-smallcheck-0.3.0:=[profile?]
- >=dev-haskell/lifted-base-0.2.3.3:=[profile?]
- >=dev-haskell/monad-control-0.3.3.0:=[profile?]
- >=dev-haskell/mono-traversable-0.7.0:=[profile?]
- >=dev-haskell/network-2.6.0.2:=[profile?]
- >=dev-haskell/primitive-0.6:=[profile?]
- >=dev-haskell/resourcet-1.1.3.3:=[profile?]
- >=dev-haskell/safe-0.3.8:=[profile?]
- >=dev-haskell/semigroups-0.8:=[profile?]
- >=dev-haskell/smallcheck-1.1.1:=[profile?]
- >=dev-haskell/store-core-0.4:=[profile?] <dev-haskell/store-core-0.5:=[profile?]
- >=dev-haskell/syb-0.4.4:=[profile?]
- >=dev-haskell/text-1.2.0.4:=[profile?]
- >=dev-haskell/th-lift-0.7.1:=[profile?]
- >=dev-haskell/th-lift-instances-0.1.4:=[profile?]
- >=dev-haskell/th-orphans-0.13.2:=[profile?]
- >=dev-haskell/th-reify-many-0.1.6:=[profile?]
- >=dev-haskell/th-utilities-0.2:=[profile?]
- >=dev-haskell/unordered-containers-0.2.5.1:=[profile?]
- >=dev-haskell/vector-0.10.12.3:=[profile?]
- >=dev-haskell/void-0.5.11:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
-"
-# test? ( >=dev-haskell/clock-0.3 )
-# "
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-comparison-bench \
- --flag=-small-bench
-}