summaryrefslogtreecommitdiff
path: root/dev-haskell/sendfile/sendfile-0.7.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/sendfile/sendfile-0.7.9.ebuild')
-rw-r--r--dev-haskell/sendfile/sendfile-0.7.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/sendfile/sendfile-0.7.9.ebuild b/dev-haskell/sendfile/sendfile-0.7.9.ebuild
new file mode 100644
index 000000000000..aea9e2a5f8c8
--- /dev/null
+++ b/dev-haskell/sendfile/sendfile-0.7.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A portable sendfile library"
+HOMEPAGE="http://hub.darcs.net/stepcut/sendfile"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="portable"
+
+RDEPEND="=dev-haskell/network-2*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag portable portable)
+}