summaryrefslogtreecommitdiff
path: root/dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild')
-rw-r--r--dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild b/dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild
new file mode 100644
index 000000000000..a82bf7c7b332
--- /dev/null
+++ b/dev-haskell/resolv/resolv-0.1.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: needs a port to new srcloc
+inherit haskell-cabal
+
+DESCRIPTION="Domain Name Service (DNS) lookup via the libresolv standard library routines"
+HOMEPAGE="https://hackage.haskell.org/package/resolv"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails to build test suite
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+"
+
+src_prepare() {
+ default
+ cabal_chdeps \
+ 'base >= 4.5 && <4.15' 'base >= 4.5' \
+ 'base16-bytestring ^>= 0.1' 'base16-bytestring >= 0.1' \
+ 'bytestring ^>=0.9.2 || ^>= 0.10' 'bytestring >=0.9.2'
+ eapply_user
+}