summaryrefslogtreecommitdiff
path: root/dev-haskell/regex-compat-tdfa
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-compat-tdfa')
-rw-r--r--dev-haskell/regex-compat-tdfa/Manifest3
-rw-r--r--dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch11
-rw-r--r--dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild6
3 files changed, 17 insertions, 3 deletions
diff --git a/dev-haskell/regex-compat-tdfa/Manifest b/dev-haskell/regex-compat-tdfa/Manifest
index c725894b71fe..cf0d69377dd2 100644
--- a/dev-haskell/regex-compat-tdfa/Manifest
+++ b/dev-haskell/regex-compat-tdfa/Manifest
@@ -1,3 +1,4 @@
+AUX regex-compat-tdfa-0.95.1.4-ghc-9.0.patch 470 BLAKE2B 9044e7b95b5d6a03df35d9e1198de43db24c1ec9ab22e00cce9c405b68048bebd7532cf39e21ee3edea1aa0f985409070ea6d805245048c7775f0635755618b1 SHA512 15dd9c61b60335c51d906ba235d242d80b248d31a563dd1b82aca2385bedd67f481757cae6e7bf9c55ce30b44c32d897ed6475027d7e32efd29cba18181dd26d
DIST regex-compat-tdfa-0.95.1.4.tar.gz 4146 BLAKE2B 1749307b8a7bfb1f0a0137febf425191d225bcdfbb0517034ea31e11e648eac128f16cc1951f9471e9f22efeb296c1c32344a375c16381ef823e0fc4674e730f SHA512 7e387a7713ff8e43cfce4262b1288b85f8b60729162a842186bf6a7e1078dfb9e26013087ff7e9bcf81521f8c352926873bb280b9df57b016aef2ca4ce70aa14
-EBUILD regex-compat-tdfa-0.95.1.4.ebuild 805 BLAKE2B bfe4f75385f7047bea679257184db1126b18ad8212f6c71b7eaaf4bf3ad011c07d704c7fabef9971ffc1c6bc0c919628e6d1eddd9044a9d34f4cec4474425637 SHA512 be9b4c8945f35b022facfbbf7680edcd50b52f27eb8ac484941ad651bec123c0cf2130434a0c09680edc7f72e0ec34db1516f8d94b82dd327f13daa0c72f4992
+EBUILD regex-compat-tdfa-0.95.1.4.ebuild 862 BLAKE2B 8c88b241895122b6225e2387a125cd0364c46317932457ad5eae14ac4993da97048729dd219266e6f6423bbc737235e74e225b54ba576cae3191e8b871514d5b SHA512 a6494eeb917aac5143dee688f68308c9720db5c98a3fedc31dbd01b98f7c6f10eab1791145366185da89055f6da22a798043ddcf0a7402a921b97cf0edbffe65
MISC metadata.xml 250 BLAKE2B 3adf9597d5114c480b4cc9fb5c3e231d8475b795cd6dce77986e13583ab6e59b43857cf2328570490abef0062a8b8a6b73d231867f9b62124855515cdc044d6d SHA512 5ef2c1d34a3438b39a38c041d45bb06bd0f1ae8a3f8b971bd5aaf36dee560f380e9abefab0c2a4cd7b518e151f5c6a0d0c7cd53caee9a384818f1bdc7deeadc4
diff --git a/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch b/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch
new file mode 100644
index 000000000000..78d0ceb93575
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch
@@ -0,0 +1,11 @@
+--- regex-compat-tdfa-0.95.1.4-orig/Text/Regex.hs 2021-06-25 10:08:26.670791461 +1000
++++ regex-compat-tdfa-0.95.1.4/Text/Regex.hs 2021-06-25 10:08:10.325737439 +1000
+@@ -139,7 +139,7 @@
+ splitRegex :: Regex -> String -> [String]
+ splitRegex _ [] = []
+ splitRegex delim strIn =
+- let matches = map (!0) (matchAll delim strIn)
++ let matches = map (! 0) (matchAll delim strIn)
+ go _i str [] = str : []
+ go i str ((off,len):rest) =
+ let i' = off+len
diff --git a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
index efe655a7cf3b..71c308c67193 100644
--- a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
+++ b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Unicode Support version of Text.Regex, using regex-tdfa"
-HOMEPAGE="http://hub.darcs.net/shelarcy/regex-compat-tdfa"
+HOMEPAGE="https://hub.darcs.net/shelarcy/regex-compat-tdfa"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
+PATCHES=( "${FILESDIR}"/${PN}-0.95.1.4-ghc-9.0.patch )
+
src_configure() {
haskell-cabal_src_configure \
--flag=newbase \