summaryrefslogtreecommitdiff
path: root/dev-haskell/monad-par
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-par')
-rw-r--r--dev-haskell/monad-par/Manifest5
-rw-r--r--dev-haskell/monad-par/metadata.xml29
-rw-r--r--dev-haskell/monad-par/monad-par-0.3.4.7.ebuild44
-rw-r--r--dev-haskell/monad-par/monad-par-0.3.4.8.ebuild44
4 files changed, 0 insertions, 122 deletions
diff --git a/dev-haskell/monad-par/Manifest b/dev-haskell/monad-par/Manifest
deleted file mode 100644
index 2a2d4aab9a04..000000000000
--- a/dev-haskell/monad-par/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST monad-par-0.3.4.7.tar.gz 30411 BLAKE2B b7ed0e6e10c992fb3c2cb75813f180b6124215902aa5decd66d96ada7fc14623a3a1b2c4cfe9cf863087643091ebe24da3099e4f4652a4d1fce17f5cd71eb2f0 SHA512 eb9bd155589e9e7aea51e8b79f7fca20cfc8ac0dabf9c475fbbb312139311d567e1f19779247fd331c8242c93c9cefc1d52fca599c6444f90194d2a193182772
-DIST monad-par-0.3.4.8.tar.gz 30583 BLAKE2B c0d31959d7f1b50eb763810e4199b2a7a27b8ca202f078d23b6ae5c62f94cadbf5f7169959e577d59d0bb85cfe450af06e71b85410573ec50f37d9c36b458411 SHA512 6d2f6f571a3eef804e69ca892cf865bb169863d4fa97cad94cfb740925861b827fef14595c2edf235a8a60babdb854eecb87ff09bb798a6912edb7c3c6fe7027
-EBUILD monad-par-0.3.4.7.ebuild 1225 BLAKE2B 426470c1ac5b4cda0fae6a9015caf74e54166314676e6e42aa07eec0657076a37cdd40fb089ffca8fa86db6d87b0774e4e11d135c946c0f912185d8bdb84c84f SHA512 6f7f939f637c7a907b4d012fa6ba1adf09bda4728cb5fb500a20525f4e03d088ba9ae12b14b1a134692fafbdd0a668ffb698c435fba4258813ebd34677cfc2f6
-EBUILD monad-par-0.3.4.8.ebuild 1223 BLAKE2B dfefddc149a4743cd5ad8826fbf9a03632011a98e939d848c99cbb1c1ae4232b636848e248581b8e6c9e33ace0b2e2755f5974357c06624471f111ba0b7bdeea SHA512 eefa9555182a83955e1a77583c51326d365bb2d628f2faa3a8e8276786672ed0845139c0a8c62a1519db3c2ee34c954291674c697a6379091a9537e11a1d60be
-MISC metadata.xml 1071 BLAKE2B bd9d53b00250f7af1fdb89c4853a3f06c09be12014bc887bbfb5d5d24984b992765b109833f350664bca345d16b7a1295c5f44513e11f86aaf5f28abb88a17ae SHA512 45e21f883fd57087d030acd80b6ef45538cc357f9b1572c2cfc080330e8a6a59226af9c3e8bd40a7a5ca3839aa427b03e5d7df88fdbd75daf928379531d88729
diff --git a/dev-haskell/monad-par/metadata.xml b/dev-haskell/monad-par/metadata.xml
deleted file mode 100644
index 42da13462ec1..000000000000
--- a/dev-haskell/monad-par/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This library offers an alternative parallel programming
- API to that provided by the @parallel@ package.
- The 'Par' monad allows the simple description of
- parallel computations, and can be used to add
- parallelism to pure Haskell code. The basic API
- is straightforward: the monad supports forking
- and simple communication in terms of 'IVar's.
- The library comes with an efficient work-stealing
- implementation, but the internals are also
- exposed so that you can build your own scheduler
- if necessary.
- Examples of use can be found in the examples/ directory
- of the source package.
- </longdescription>
- <use>
- <flag name="chaselev">Use Chase-Lev Deques for higher-perf work-stealing.</flag>
- </use>
- <upstream>
- <remote-id type="github">simonmar/monad-par</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild b/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
deleted file mode 100644
index 5f493ba60cc4..000000000000
--- a/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-#hackport: flags: -newgeneric
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A library for parallel programming based on a monad"
-HOMEPAGE="https://github.com/simonmar/monad-par"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="chaselev"
-
-RDEPEND=">=dev-haskell/abstract-deque-0.1.4:=[profile?]
- dev-haskell/abstract-par:=[profile?]
- >=dev-haskell/monad-par-extras-0.3:=[profile?]
- >=dev-haskell/mtl-2.0.1.0:=[profile?]
- >=dev-haskell/mwc-random-0.11:=[profile?]
- >=dev-haskell/parallel-3.1:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- chaselev? ( dev-haskell/chaselev-deque:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit
- dev-haskell/quickcheck
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit
- >=dev-haskell/test-framework-quickcheck2-0.3
- dev-haskell/test-framework-th )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag chaselev chaselev) \
- --flag=-newgeneric
-}
diff --git a/dev-haskell/monad-par/monad-par-0.3.4.8.ebuild b/dev-haskell/monad-par/monad-par-0.3.4.8.ebuild
deleted file mode 100644
index 0ba679fe4206..000000000000
--- a/dev-haskell/monad-par/monad-par-0.3.4.8.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.9999
-#hackport: flags: -newgeneric
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A library for parallel programming based on a monad"
-HOMEPAGE="https://github.com/simonmar/monad-par"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="chaselev"
-
-RDEPEND=">=dev-haskell/abstract-deque-0.1.4:=[profile?]
- dev-haskell/abstract-par:=[profile?]
- >=dev-haskell/monad-par-extras-0.3:=[profile?]
- >=dev-haskell/mtl-2.0.1.0:=[profile?]
- >=dev-haskell/mwc-random-0.11:=[profile?]
- >=dev-haskell/parallel-3.1:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- chaselev? ( dev-haskell/chaselev-deque:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit
- dev-haskell/quickcheck
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit
- >=dev-haskell/test-framework-quickcheck2-0.3
- dev-haskell/test-framework-th )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag chaselev chaselev) \
- --flag=-newgeneric
-}