summaryrefslogtreecommitdiff
path: root/dev-haskell/megaparsec/megaparsec-8.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/megaparsec/megaparsec-8.0.0.ebuild')
-rw-r--r--dev-haskell/megaparsec/megaparsec-8.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/megaparsec/megaparsec-8.0.0.ebuild b/dev-haskell/megaparsec/megaparsec-8.0.0.ebuild
new file mode 100644
index 000000000000..aba2ec44c287
--- /dev/null
+++ b/dev-haskell/megaparsec/megaparsec-8.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.5.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic parser combinators"
+HOMEPAGE="https://github.com/mrkkrp/megaparsec"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/mtl-2.2.2:=[profile?] <dev-haskell/mtl-3.0:=[profile?]
+ >=dev-haskell/parser-combinators-1.0:=[profile?] <dev-haskell/parser-combinators-2.0:=[profile?]
+ >=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-0.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=-dev
+}