summaryrefslogtreecommitdiff
path: root/dev-haskell/hxt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/Manifest4
-rw-r--r--dev-haskell/hxt/hxt-9.3.1.22.ebuild (renamed from dev-haskell/hxt/hxt-9.3.1.18.ebuild)16
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-haskell/hxt/Manifest b/dev-haskell/hxt/Manifest
index b3ce6afa7787..7f7fe009de5c 100644
--- a/dev-haskell/hxt/Manifest
+++ b/dev-haskell/hxt/Manifest
@@ -1,3 +1,3 @@
-DIST hxt-9.3.1.18.tar.gz 223887 BLAKE2B 35d48b60496fc365b4ba493a8cec186fd379ee360fcf311b4529c617f4a7cf825c6547edf3ba3c7b7f5cfff14e05a0fceff71ccab8a45609f445c5c4fd29c468 SHA512 4b7c57486fe02357a45b5f835dd9f05333ce39578ec84c3c920fdcaa2df8ae1067da3650d3948559ddaf2e6f77f14291e1ddaa28a12ea9dfb62a797d296ec118
-EBUILD hxt-9.3.1.18.ebuild 950 BLAKE2B 2ccacd53c502b487624b6e59c3c45080decf227da4bdbb4259f5fee1929e4cfd5f13dd40fdaa35a379461b11dc4b923a515cdf42e8ee22ead732ccf87564330f SHA512 7df9944c51d796da4fa1699b45fb91fc0ffde4b817cceb71b793a2006129bbf52959aea57553e9537a110530d906219205f637324ea5e83171605563e44d500c
+DIST hxt-9.3.1.22.tar.gz 224934 BLAKE2B bbe83adfc1506bad54e20859c91bff04a6b15ca9ece0a90455bb54b77eb55414dd0428656fb641af06e903d17f32a25389fb52bac066d5c51a79e5c4985298ab SHA512 ac7720a01a7769bfb528aa5de29fff9a993c430af75d1326bd50e845c3b7378be09bdda8c99bdd7e45fc5c09fac10c6fc318ff77cf65b2ad7ea2709aff2c1af8
+EBUILD hxt-9.3.1.22.ebuild 1028 BLAKE2B 4739b5516ef2c1b63fbbf8b5269fbb5afbcbb5a7f368ae0ebb17ddf0e20ba6a5eabe7703de3e48fb5bb3fd5720347878c075b43e1f0e634dfff72383334dca72 SHA512 4b71ba1791948071a5117556687c87e7561dbdf64dc4629262cabfc09f793ccc52533da13225b2ac6404da6f948f86e08c4d40dc07ffbe508ce786892eb5d133
MISC metadata.xml 1294 BLAKE2B b3c309d76bb64d89b089ed74622c15c325b62aded75f9c6c64a8eab944f2799c401176eced495db7fcca949fd1362589141df4ff2d7a36d2e90607846c7f4e43 SHA512 f6b70c76bf6334df21ee7674cc542d7567a480136bc3064d4037cb8b14933a4d9af48bb4123e62366c49cc8e88c66910b2af53fe534de457ed7d73ad1a44b964
diff --git a/dev-haskell/hxt/hxt-9.3.1.18.ebuild b/dev-haskell/hxt/hxt-9.3.1.22.ebuild
index 2a562ce245da..aac5424955fc 100644
--- a/dev-haskell/hxt/hxt-9.3.1.18.ebuild
+++ b/dev-haskell/hxt/hxt-9.3.1.22.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# ebuild generated by hackport 0.6.9999
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +network-uri
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -15,21 +16,22 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="profile"
RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
>=dev-haskell/hxt-regex-xmlschema-9.2:=[profile?]
>=dev-haskell/hxt-unicode-9.0.1:=[profile?]
>=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
- >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
- >=dev-lang/ghc-7.4.1:=
>=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
+ >=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
- --flag=network-uri
+ --flag=network-uri \
+ $(cabal_flag profile profile)
}