summaryrefslogtreecommitdiff
path: root/dev-haskell/hxt/hxt-9.3.1.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hxt/hxt-9.3.1.18.ebuild')
-rw-r--r--dev-haskell/hxt/hxt-9.3.1.18.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hxt/hxt-9.3.1.18.ebuild b/dev-haskell/hxt/hxt-9.3.1.18.ebuild
new file mode 100644
index 000000000000..1902e81622f6
--- /dev/null
+++ b/dev-haskell/hxt/hxt-9.3.1.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="https://github.com/UweSchmidt/hxt"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
+ >=dev-haskell/hxt-regex-xmlschema-9.2:=[profile?]
+ >=dev-haskell/hxt-unicode-9.0.1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}