summaryrefslogtreecommitdiff
path: root/dev-haskell/http-api-data
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-api-data')
-rw-r--r--dev-haskell/http-api-data/Manifest5
-rw-r--r--dev-haskell/http-api-data/http-api-data-0.4.3.ebuild58
-rw-r--r--dev-haskell/http-api-data/metadata.xml3
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-haskell/http-api-data/Manifest b/dev-haskell/http-api-data/Manifest
index 4a8bac04eee6..b95872c0dbff 100644
--- a/dev-haskell/http-api-data/Manifest
+++ b/dev-haskell/http-api-data/Manifest
@@ -1,3 +1,6 @@
DIST http-api-data-0.4.1.1.tar.gz 19800 BLAKE2B 1dea8465ca41d6a8afdc1a994bec79e2fd58889732275dd0dfab73b917e1ae7b21824ba36ba83471d82e18f4ebe05265655098912c4136fd4a250070641c5c74 SHA512 9b768dc790999e42a82753b69f6ab48df90721468eaff79bf4b9a1eb08572dba3488908db4ad0a1afb3956513a16fcd663f005856e230748f665987766e10c59
+DIST http-api-data-0.4.3.cabal 3845 BLAKE2B fdde464e0c378bd60b135fd325bd2263df2eef42f797c1aa7b04e9382027b58498c80414a75dd83278d3bdf5676041c3ed2493b918d87eda3140ccddecc410b8 SHA512 cbf03caa0a026cad8c327b9fdf04dcc447dab3879c9cacf8fe7cf118665b9466983660937684fe8d14b7c50a29d7fa8a5f8f2eb2e8febc9d8217f3d30888e5d5
+DIST http-api-data-0.4.3.tar.gz 20827 BLAKE2B 04e7f0a9e5edebc230b47640c6a86dc76d271942cc70d0aa109d289fe2b1139e4c8103ba0799990b4c7ea0a37f3dd46ac4a72e9a5e4a39029d856e134ebfe8fb SHA512 625367d8f524eff07c69620df17c87a4365c01b9bc8bdd6bab5b8abe1b47cc429a050d63f48e50cb08fcac55aef95dfea532a5d52c87b6fa2d3e58b06aa8f4b0
EBUILD http-api-data-0.4.1.1.ebuild 2235 BLAKE2B 76eda71dd0eb62a2ac7ecc8e455ae7d75d21fd9144b8654ed93fcf5c68fe23071640a034fdaffec1e6acad3f0297730efcc10da9cf2147f3b424b53bbb9deabb SHA512 c8954f6394dbf3b3911adfb9208a686de9c51738178408cf47ef60bef421cf5ae31d18c0fd837c86811acde72da27d110b3b9b70c819e0ac387d311a537b09e9
-MISC metadata.xml 335 BLAKE2B cb8c783459f076fcab7cdc8aa5ae7745bd93b1645ccc3ec41600d4d54fb361f7b4fec715206ebc941e6bb66288d13e9a9c734dae0a8ff7e3efb0aa7fd240202c SHA512 5fbe693d4148c7bb40237115a65822881e949654b74f08d275e0d79a5da672587ba112af07ced5d52439b22abb6f369c6fa8709a8aedb29f0e4456c30dd6815e
+EBUILD http-api-data-0.4.3.ebuild 2309 BLAKE2B 3a10503254995908bff0b35850d3b9fab0e42642f8165a36bf6a2637549d5c01cae7ada6bcf7d36e7766f7747358621a7db4846a6b73143f53f517a815da1b6c SHA512 154813c7f7e531a974e72a89d24122ef8b1ac3e14d317ed24402963da590343071bb44b338121f069c08c4563ae10e535736cdb89050bbf1edab1f4b01284720
+MISC metadata.xml 448 BLAKE2B 708be06baddd59c81fddffbd8bb36e23617b3e915234157a108b7c0f5607c0e50a8e6d0d8aeff51477b2b413a21d9a51000a96e55526cccf65a3484ebe438fe6 SHA512 770923b4a23b3093f0ce1e780be8efe80668ee76c61bb28d1e0fd4b3114c5802babb784914f32a323b801e8d715e9dedd4422b56ef97a53aa9da7ae423060f0d
diff --git a/dev-haskell/http-api-data/http-api-data-0.4.3.ebuild b/dev-haskell/http-api-data/http-api-data-0.4.3.ebuild
new file mode 100644
index 000000000000..e84807a4ded7
--- /dev/null
+++ b/dev-haskell/http-api-data/http-api-data-0.4.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Converting to/from HTTP API data like URL pieces, headers and query parameters"
+HOMEPAGE="https://github.com/fizruk/https-api-data"
+HACKAGE_REV="6"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="text-show"
+
+RDEPEND=">=dev-haskell/attoparsec-0.13.2.2:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-haskell/attoparsec-iso8601-1.0.2.0:=[profile?] <dev-haskell/attoparsec-iso8601-1.1:=[profile?]
+ >=dev-haskell/base-compat-0.10.5:=[profile?] <dev-haskell/base-compat-0.13:=[profile?]
+ >=dev-haskell/cookie-0.4.3:=[profile?] <dev-haskell/cookie-0.5:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/http-types-0.12.3:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/tagged-0.8.5:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/time-compat-1.9.5:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.10.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ text-show? ( >=dev-haskell/text-show-3.8.2:=[profile?] <dev-haskell/text-show-3.10:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2.7.1 <dev-haskell/hspec-2.10
+ >=dev-haskell/hunit-1.6.0.0 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.13.1 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/quickcheck-instances-0.3.25.2 <dev-haskell/quickcheck-instances-0.4 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag text-show use-text-show)
+}
diff --git a/dev-haskell/http-api-data/metadata.xml b/dev-haskell/http-api-data/metadata.xml
index 145f1adbf832..82af2cfcc5a0 100644
--- a/dev-haskell/http-api-data/metadata.xml
+++ b/dev-haskell/http-api-data/metadata.xml
@@ -5,6 +5,9 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="text-show">Use text-show library for efficient ToHttpApiData implementation.</flag>
+ </use>
<upstream>
<remote-id type="github">fizruk/http-api-data</remote-id>
</upstream>