summaryrefslogtreecommitdiff
path: root/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild')
-rw-r--r--dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild b/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild
new file mode 100644
index 000000000000..4d6060d2afb2
--- /dev/null
+++ b/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HsYAML-aeson"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="JSON to YAML Adapter"
+HOMEPAGE="https://hackage.haskell.org/package/HsYAML-aeson"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.4.0.0:=[profile?] <dev-haskell/aeson-1.6:=[profile?]
+ >=dev-haskell/hsyaml-0.2.0:=[profile?] <dev-haskell/hsyaml-0.3:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3.6.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.12.0.2:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.14' 'base >= 4.5' \
+ 'containers >=0.4.2 && <0.7' 'containers >=0.4.2'
+}