summaryrefslogtreecommitdiff
path: root/dev-haskell/hps/hps-0.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hps/hps-0.15.ebuild')
-rw-r--r--dev-haskell/hps/hps-0.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/hps/hps-0.15.ebuild b/dev-haskell/hps/hps-0.15.ebuild
new file mode 100644
index 000000000000..0e5de65a0b07
--- /dev/null
+++ b/dev-haskell/hps/hps-0.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell Postscript"
+HOMEPAGE="http://rd.slavepianos.org/?t=hps"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="build-exec"
+
+RDEPEND=">=dev-haskell/hcg-minus-0.15:=[profile?] <dev-haskell/hcg-minus-0.16:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ build-exec? ( dev-haskell/random:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag build-exec build-exec)
+}