summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild
deleted file mode 100644
index 37ee78d5920d..000000000000
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.5.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
-inherit haskell-cabal
-
-MY_PN="HDBC-postgresql"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL driver for HDBC"
-HOMEPAGE="https://github.com/hdbc/hdbc-postgresql"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="2/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="test" # requires configured postgresql
-
-RDEPEND=">=dev-db/postgresql-7:*
- dev-haskell/convertible:=[profile?]
- >=dev-haskell/hdbc-2.2.0:2=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/old-locale:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/parsec:=[profile?]
- dev-haskell/utf8-string:=[profile?]
- >=dev-lang/ghc-6.12.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8.0.2
- test? ( >=dev-haskell/hdbc-2.2.6:=[profile?]
- dev-haskell/hunit:=[profile?]
- dev-haskell/quickcheck:2=[profile?]
- dev-haskell/testpack:=[profile?] )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag test buildtests)
-}
-
-src_test() {
- # default tests
- haskell-cabal_src_test || die "cabal test failed"
-
- # built custom tests
- "${S}/dist/build/runtests/runtests" || die "unit tests failed"
-}
-
-src_install() {
- cabal_src_install
-
- # if tests were enabled, make sure the unit test driver is deleted
- rm -f "${ED}/usr/bin/runtests"
-}