summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild')
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild
new file mode 100644
index 000000000000..ce4e1c94bf63
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="https://github.com/ryantm/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:2=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ dev-libs/openssl
+ sys-libs/zlib
+ >=virtual/mysql-4.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}