summaryrefslogtreecommitdiff
path: root/dev-haskell/hcodecs/hcodecs-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hcodecs/hcodecs-0.5.1.ebuild')
-rw-r--r--dev-haskell/hcodecs/hcodecs-0.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/hcodecs/hcodecs-0.5.1.ebuild b/dev-haskell/hcodecs/hcodecs-0.5.1.ebuild
new file mode 100644
index 000000000000..87755879d76f
--- /dev/null
+++ b/dev-haskell/hcodecs/hcodecs-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HCodecs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library to read, write and manipulate MIDI, WAVE, and SoundFont2 files"
+HOMEPAGE="http://www-db.informatik.uni-tuebingen.de/team/giorgidze"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # QC finds counterexamples
+
+RDEPEND=">=dev-haskell/quickcheck-2.0:2=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"