summaryrefslogtreecommitdiff
path: root/dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild')
-rw-r--r--dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild b/dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild
new file mode 100644
index 000000000000..99b970d30f58
--- /dev/null
+++ b/dev-haskell/happstack-server/happstack-server-7.1.7.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Web related tools and services"
+HOMEPAGE="http://happstack.com"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+#hackport: ignore-flag network_2_2_3 ; flag for old network compatibility
+#hackport: ignore-flag template_haskell: non GHC compiler
+IUSE=""
+
+RDEPEND="=dev-haskell/base64-bytestring-1.0*:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hslogger-1.0.2:=[profile?]
+ dev-haskell/html:=[profile?]
+ =dev-haskell/monad-control-0.3*:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ >=dev-haskell/sendfile-0.7.1:=[profile?]
+ <dev-haskell/sendfile-0.8:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/system-filepath-0.3.1:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/threads-0.5:=[profile?]
+ dev-haskell/time-compat:=[profile?]
+ >=dev-haskell/transformers-0.1.3:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ =dev-haskell/transformers-base-0.4*:=[profile?]
+ >=dev-haskell/utf8-string-0.3.4:=[profile?]
+ <dev-haskell/utf8-string-0.4:=[profile?]
+ dev-haskell/xhtml:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ >=dev-haskell/network-2.2.3:=[profile?]
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ )"