summaryrefslogtreecommitdiff
path: root/dev-haskell/haddock/haddock-2.25.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haddock/haddock-2.25.1.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-2.25.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/haddock/haddock-2.25.1.ebuild b/dev-haskell/haddock/haddock-2.25.1.ebuild
new file mode 100644
index 000000000000..f45e6bbd700c
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.25.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7
+#hackport: flags: -in-ghc-tree
+
+CABAL_FEATURES="" # broken test-suite
+inherit haskell-cabal
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="https://www.haskell.org/haddock/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+#keep in sync with ghc-9.0.2
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # missing test-suite
+
+RDEPEND="~dev-haskell/haddock-api-2.25.1:=
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-in-ghc-tree
+}