summaryrefslogtreecommitdiff
path: root/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild')
-rw-r--r--dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild b/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild
new file mode 100644
index 000000000000..13485cc9e6e6
--- /dev/null
+++ b/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -test-parsing
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to Graphviz for graph visualisation"
+HOMEPAGE="http://projects.haskell.org/graphviz/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/colour-2.3:=[profile?] <dev-haskell/colour-2.4:=[profile?]
+ >=dev-haskell/dlist-0.5:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/fgl-5.4:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
+ >=dev-haskell/polyparse-1.9:=[profile?] <dev-haskell/polyparse-1.13:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-haskell/wl-pprint-text-1.1.0.0:=[profile?] <dev-haskell/wl-pprint-text-1.2.0.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/fgl-arbitrary-0.2 <dev-haskell/fgl-arbitrary-0.3
+ >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.10 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test-parsing
+}