summaryrefslogtreecommitdiff
path: root/dev-haskell/glut/glut-2.7.0.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/glut/glut-2.7.0.15.ebuild')
-rw-r--r--dev-haskell/glut/glut-2.7.0.15.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/glut/glut-2.7.0.15.ebuild b/dev-haskell/glut/glut-2.7.0.15.ebuild
new file mode 100644
index 000000000000..a02bf667d8b7
--- /dev/null
+++ b/dev-haskell/glut/glut-2.7.0.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -usenativewindowslibraries,buildexamples:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="GLUT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL Utility Toolkit"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-haskell/opengl-2.12:=[profile?] <dev-haskell/opengl-3.1:=[profile?]
+ >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ examples? ( >=dev-haskell/openglraw-1.0:=[profile?] <dev-haskell/openglraw-3.4:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples buildexamples) \
+ --flag=-usenativewindowslibraries
+}