summaryrefslogtreecommitdiff
path: root/dev-haskell/file-location
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/file-location')
-rw-r--r--dev-haskell/file-location/Manifest3
-rw-r--r--dev-haskell/file-location/file-location-0.4.9.1.ebuild29
-rw-r--r--dev-haskell/file-location/metadata.xml42
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-haskell/file-location/Manifest b/dev-haskell/file-location/Manifest
deleted file mode 100644
index 91457268b5fe..000000000000
--- a/dev-haskell/file-location/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST file-location-0.4.9.1.tar.gz 6961 BLAKE2B 5b3248db2a03ad699ba1354a88b6d0aa4e124e607be6692e7be7a9cec403d42dcb2e304a60c85e879855a9e5e3e49309d8aa112edaa12986f79b8408fa49b781 SHA512 a84a6ed3ff1a786331e202ae505df3981e81b3ce085e588632868357626b82a559dc649aa1623a09462741c5133ee0e5d5deb10713d94cc8286b82aa2e706d94
-EBUILD file-location-0.4.9.1.ebuild 736 BLAKE2B c344f2e3c9cbd25a1a65c7f76c5e547f169123345f11490e62b2863f2bf08c5c6335774db74d7e14f7fe0e54238827551ceb00dd70658804e60940d7d40decc1 SHA512 3051aa027accfbaa7f7dcca9d6da3b989a1fdb2c5be3f5a7cd07f6aa6dd4328124517747f15971cc61ce17b854151218b5886adca9bf2e1f9d2278b4bd1ada1d
-MISC metadata.xml 1439 BLAKE2B 12142fc860b8846cb961f641ab0a7899c2911e55a5b92608ac34cc031ec89b0c870bcf257a017d5668a228c33e86098fd8451dd1022296557599afbf37a1806e SHA512 4b7f9f55f42daf54a69cff31d3e71e7279aa510813547a9df4198c870d0ae996565928921328af9b1d7660a83f7dcc2a5b9062d30312e4159aab04750488b6c1
diff --git a/dev-haskell/file-location/file-location-0.4.9.1.ebuild b/dev-haskell/file-location/file-location-0.4.9.1.ebuild
deleted file mode 100644
index fbf5ddd465cf..000000000000
--- a/dev-haskell/file-location/file-location-0.4.9.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.5.2.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="common functions that show file location information"
-HOMEPAGE="https://github.com/gregwebs/FileLocation.hs"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # error stack changed from ghc-7.10
-
-RDEPEND="dev-haskell/hunit:=[profile?]
- dev-haskell/lifted-base:=[profile?]
- >=dev-haskell/th-orphans-0.9:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
-"
diff --git a/dev-haskell/file-location/metadata.xml b/dev-haskell/file-location/metadata.xml
deleted file mode 100644
index 26c45b3b64ae..000000000000
--- a/dev-haskell/file-location/metadata.xml
+++ /dev/null
@@ -1,42 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Common debugging/error/exception functions that give file location information
-
- &gt; $(err "OH NO!")
- &gt;
- &gt; main:Main main.hs:16:1 OH NO!
-
- Notice how it displays package:module file:line:character
- It exposes the functions err (error), undef (undefined), and trc (Debug.Trace.trace). All of these behave the same as their normal counterpart but also spit out a location.
-
- Here is my favorite helper, debug, which is like trace but just show the value.
-
- &gt; debug [1,2,3]
- &gt;
- &gt; DEBUG: [1,2,3]
- &gt; [1,2,3]
-
- And The Template Haskell version.
-
- &gt; $(dbg) [1,2,3]
- &gt;
- &gt; DEBUG main:Main main.hs:1:3 [1,2,3]
- &gt; [1,2,3]
-
- Also there is a version of thrwIO that gives location information
- &gt; ($(thrwIO) $ AException) `catch` \e -&gt; putStrLn ("Caught " ++ show (e :: AException))
- &gt;
- &gt; Caught AException "main:Main test/main.hs:25:6"
-
- See module for a listing of all the functions with short descriptions, and the homepage for some more examples https://github.com/gregwebs/ErrorLocation.hs
- </longdescription>
- <upstream>
- <remote-id type="github">gregwebs/FileLocation.hs</remote-id>
- </upstream>
-</pkgmetadata>