summaryrefslogtreecommitdiff
path: root/dev-haskell/fclabels/fclabels-2.0.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/fclabels/fclabels-2.0.3.3.ebuild')
-rw-r--r--dev-haskell/fclabels/fclabels-2.0.3.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/fclabels/fclabels-2.0.3.3.ebuild b/dev-haskell/fclabels/fclabels-2.0.3.3.ebuild
new file mode 100644
index 000000000000..f9cd7dee05f4
--- /dev/null
+++ b/dev-haskell/fclabels/fclabels-2.0.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="First class accessor labels implemented as lenses"
+HOMEPAGE="https://github.com/sebastiaanvisser/fclabels"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.12' 'base >= 4.5' \
+ 'HUnit >= 1.2 && < 1.7' 'HUnit >= 1.2' \
+ 'template-haskell >= 2.2 && < 2.14' 'template-haskell >= 2.2'
+}