summaryrefslogtreecommitdiff
path: root/dev-haskell/enumerator
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/enumerator')
-rw-r--r--dev-haskell/enumerator/Manifest4
-rw-r--r--dev-haskell/enumerator/enumerator-0.4.20.ebuild30
-rw-r--r--dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch21
-rw-r--r--dev-haskell/enumerator/metadata.xml47
4 files changed, 0 insertions, 102 deletions
diff --git a/dev-haskell/enumerator/Manifest b/dev-haskell/enumerator/Manifest
deleted file mode 100644
index fd46c2ae12e1..000000000000
--- a/dev-haskell/enumerator/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX enumerator-0.4.20-ghc84.patch 590 BLAKE2B eb079893035685d0dcc19f1bf1ec3e7002c21ada581d8b8002d1d1713e575de8aa79dd98dfa677cdc51f9829cb7695ef67c61f73e65042c8a848ffb113724243 SHA512 f38d940bc8998c74cdc7f926a055c73940df32950d4934a5533a9495b69e8cdf28882f8dc54413c8e1095c3584802c0ef73f276ed5dc2d5609b77e4c18dfecfb
-DIST enumerator-0.4.20.tar.gz 53986 BLAKE2B dcb98c31e862194f712c2fe23193557c837d5ba658b89ea50005c2e62d2080d06740793fd4e4629d8dab5000062ef2e3908fea7071ca499e8a2e3f7ca0c1d085 SHA512 90711142b61cee2184420f4d5c9de9563afe6198cccbf5d9d8a75253b307c3df9fee388dc7770e8151f8d7b5570afdb30d8e4e597ce462302dda8430e64050ad
-EBUILD enumerator-0.4.20.ebuild 704 BLAKE2B 800b641f1dbcd164fe68968eaa6c4c4708c1b82f37a991886e38d0f43916b3defebed26bf59b14f41f7ada2338fc35d0c283531b8ff0b18500f1200155d46f15 SHA512 fb49ddea4dbd8ae954b4c2ac00b4807d8dc6becef4d80595f4f6d80207dda6eecb2363b2afdcd1d804905caee52c4b6ca0df3e5286ff86034fa23add01c9ab15
-MISC metadata.xml 2364 BLAKE2B 33719a297fb4c9a49154a8d5fc456628eec50f3be98f7df09608fc0c7d7e0aaf61093c8ad21ca6c5e01ca6701771839fdbe37ff1be316eb8c207e8768b15415d SHA512 78ad14b7d47113ef9f6647c7484c4c1298e6f0b713cc7461f293cec98320adbdb25bcd9dd878978212a39a1f10bb8e9f5ff0702fae7ad8987014eb09c4e26a6b
diff --git a/dev-haskell/enumerator/enumerator-0.4.20.ebuild b/dev-haskell/enumerator/enumerator-0.4.20.ebuild
deleted file mode 100644
index c8d35ee60ce3..000000000000
--- a/dev-haskell/enumerator/enumerator-0.4.20.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Reliable, high-performance processing with left-fold enumerators"
-HOMEPAGE="https://john-millikin.com/software/enumerator/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/text-0.7:=[profile?]
- >=dev-haskell/transformers-0.2:=[profile?]
- >=dev-lang/ghc-6.10.4:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ghc84.patch
-)
diff --git a/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch b/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch
deleted file mode 100644
index d992228d2e5c..000000000000
--- a/dev-haskell/enumerator/files/enumerator-0.4.20-ghc84.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/enumerator.cabal
-+++ b/enumerator.cabal
-@@ -152,2 +152,5 @@ library
-
-+ if !impl(ghc >= 8.0)
-+ build-depends: semigroups == 0.18.*
-+
- exposed-modules:
---- a/lib/Data/Enumerator/Internal.hs
-+++ b/lib/Data/Enumerator/Internal.hs
-@@ -50,2 +50,3 @@ import Data.Function (fix)
- import Data.Monoid (Monoid, mempty, mappend, mconcat)
-+import qualified Data.Semigroup as S
-
-@@ -73,2 +74,6 @@ instance Monad Stream where
-
-+instance S.Semigroup (Stream a) where
-+ (<>) (Chunks xs) (Chunks ys) = Chunks (xs ++ ys)
-+ (<>) _ _ = EOF
-+
- instance Monoid (Stream a) where
diff --git a/dev-haskell/enumerator/metadata.xml b/dev-haskell/enumerator/metadata.xml
deleted file mode 100644
index 3e0ee48d3525..000000000000
--- a/dev-haskell/enumerator/metadata.xml
+++ /dev/null
@@ -1,47 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Typical buffer&amp;#x2013;based incremental I/O is based around a single loop,
- which reads data from some source (such as a socket or file), transforms
- it, and generates one or more outputs (such as a line count, HTTP
- responses, or modified file). Although efficient and safe, these loops are
- all single&amp;#x2013;purpose; it is difficult or impossible to compose
- buffer&amp;#x2013;based processing loops.
-
- Haskell&amp;#x2019;s concept of &amp;#x201C;lazy I/O&amp;#x201D; allows pure code to
- operate on data from an external source. However, lazy I/O has several
- shortcomings. Most notably, resources such as memory and file handles can
- be retained for arbitrarily long periods of time, causing unpredictable
- performance and error conditions.
-
- Enumerators are an efficient, predictable, and safe alternative to lazy
- I/O. Discovered by Oleg Kiselyov, they allow large datasets to be processed
- in near&amp;#x2013;constant space by pure code. Although somewhat more complex
- to write, using enumerators instead of lazy I/O produces more correct
- programs.
-
- This library contains an enumerator implementation for Haskell, designed to
- be both simple and efficient. Three core types are defined, along with
- numerous helper functions:
-
- * /Iteratee/: Data sinks, analogous to left folds. Iteratees consume
- a sequence of /input/ values, and generate a single /output/ value.
- Many iteratees are designed to perform side effects (such as printing to
- @stdout@), so they can also be used as monad transformers.
-
- * /Enumerator/: Data sources, which generate input sequences. Typical
- enumerators read from a file handle, socket, random number generator, or
- other external stream. To operate, enumerators are passed an iteratee, and
- provide that iteratee with input until either the iteratee has completed its
- computation, or EOF.
-
- * /Enumeratee/: Data transformers, which operate as both enumerators and
- iteratees. Enumeratees read from an /outer/ enumerator, and provide the
- transformed data to an /inner/ iteratee.
- </longdescription>
-</pkgmetadata>