summaryrefslogtreecommitdiff
path: root/dev-haskell/echo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/echo')
-rw-r--r--dev-haskell/echo/Manifest6
-rw-r--r--dev-haskell/echo/echo-0.1.3.ebuild9
-rw-r--r--dev-haskell/echo/echo-0.1.4-r1.ebuild35
-rw-r--r--dev-haskell/echo/metadata.xml18
4 files changed, 46 insertions, 22 deletions
diff --git a/dev-haskell/echo/Manifest b/dev-haskell/echo/Manifest
index e42890bf78e0..5e940147964a 100644
--- a/dev-haskell/echo/Manifest
+++ b/dev-haskell/echo/Manifest
@@ -1,3 +1,5 @@
DIST echo-0.1.3.tar.gz 5373 BLAKE2B 3710de35b42e39f7ff9d2e5c2e32ae4c1e863f9ae844ada25dbb653aafd6ed261357c3b5046e9e0cabb03dd4de4f6252272a2b643087a61d1df5f26de329e588 SHA512 26a2398af231a8805b6b0a866348f848b8b8f21fe95a2fa3c781aaeae150df978335df573d46d5b07d7e4df19d6377d997f85c77049abaf0c5cb3e9998439c6f
-EBUILD echo-0.1.3.ebuild 814 BLAKE2B 1796b8de82e2383d1a0060ce4d5b229354145e5290b396d9b1d00e45ff35625fd295ba87106adb4e835094c3e8be291495eda27d7d4ee76ed21fda1753d569c4 SHA512 7edde5b8e2da2e93bd5f1a376231631237ca21fc86244dc61ae10c8dd9f83260ae949ce36345da7c25d112f49570e0c75f6a26b50631d8a6d8c45423de404c56
-MISC metadata.xml 956 BLAKE2B 096a9c7e837fd886906acaa685785b31371a82be3506de2c2325bd5d7d3b3cc623cbb23eed3d3050c3a5e7ec5b0968993b46fb232e2a3ddf6901e5dce7324b92 SHA512 1232862b850e355213649d98d6f2cf278610c5dec9ae62ae115f568e1326a5a5d3db876e5190b8cd34b156a60ec991ccba0de05f9c9afc06cc7d840ac7340ce2
+DIST echo-0.1.4.tar.gz 5501 BLAKE2B 948f5894bc67ab80423ac725c3202fcfb8e032ca73440f16c658486219ab63bd8181f1120a4bbd92834bb3a8695222cb5e3491d5dbd26045d012a90370b1a80a SHA512 25fa868be5cbbc96adb4457b0e6a2fb7060b889e0dead9acef21038fd438d1ca1ee3c57ee03d91f75271e97cfea71b1d3589f800af70e15cb8cee6a60e041477
+EBUILD echo-0.1.3.ebuild 786 BLAKE2B 4a28d5998d6064dba207bdd895bee2a98f84fcad7cee12e1c259789d246743373fc36bf9b46474fa8a22a64df11f97e18e1a72830a45c39377277ae6c280f38a SHA512 a782854a949620220437e853293fe9baaa313a3e7f262f8ae6de6ee608c038b17f468a556d035cc2b586f27e6282d4a3ad80dce1b2d0f6fb2bcf9cc31d0f6974
+EBUILD echo-0.1.4-r1.ebuild 783 BLAKE2B 07654363171146af37fef2dba014713453f4571e1241092713b711cfdc0fd91ce54398377034a4bb9e15382e01856bb2fbb5360b9399162943fabb12dc3f8970 SHA512 d2c9dec692e5f37a1c2ccaf9167754f5d0fc958490ee5f16c2a6220c352e1e2cc0201e48c4a5286e06502cbda301df620a87ff826147fc89926eda128058ff82
+MISC metadata.xml 376 BLAKE2B 5c3e4f317bda58a29e55e0e808d054f1106f20dbebd17566a9ca4287e25b1ed3c7dfe0d9608269bde2934a412b48dbae366547bcf31d1a6ff35cac2d00109127 SHA512 01399642908d02da53319f72287b396464f1ed45a817543a72a132880f1e28b5d8771b3cddbd348b88060aed2061b3a61b6ae9a346b3b42a722a65bbecdd659d
diff --git a/dev-haskell/echo/echo-0.1.3.ebuild b/dev-haskell/echo/echo-0.1.3.ebuild
index bab96c0fc27f..6a5b274cefc7 100644
--- a/dev-haskell/echo/echo-0.1.3.ebuild
+++ b/dev-haskell/echo/echo-0.1.3.ebuild
@@ -24,12 +24,9 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
-src_prepare() {
- default
-
- cabal_chdeps \
- 'process >= 1.0.1.1 && < 1.5' 'process >= 1.0.1.1'
-}
+CABAL_CHDEPS=(
+ 'process >= 1.0.1.1 && < 1.5' 'process >= 1.0.1.1'
+)
src_configure() {
haskell-cabal_src_configure \
diff --git a/dev-haskell/echo/echo-0.1.4-r1.ebuild b/dev-haskell/echo/echo-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..e79965cb0d4c
--- /dev/null
+++ b/dev-haskell/echo/echo-0.1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A cross-platform, cross-console way to handle echoing terminal input"
+HOMEPAGE="https://github.com/RyanGlScott/echo"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# Change example name to avoid name collisions
+CABAL_CHDEPS=(
+ 'executable password' 'executable haskell-echo-example'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}
diff --git a/dev-haskell/echo/metadata.xml b/dev-haskell/echo/metadata.xml
index 9d0d8cfdb8a6..db0e8f939661 100644
--- a/dev-haskell/echo/metadata.xml
+++ b/dev-haskell/echo/metadata.xml
@@ -5,18 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @base@ library exposes the @hGetEcho@ and @hSetEcho@ functions
- for querying and setting echo status, but unfortunately, neither
- function works with MinTTY consoles on Windows. This is a serious
- issue, since @hGetEcho@ and @hSetEcho@ are often used to disable
- input echoing when a program prompts for a password, so many
- programs will reveal your password as you type it on MinTTY!
-
- This library provides an alternative interface which works
- with both MinTTY and other consoles. An example is included
- which demonstrates how one might prompt for a password using
- this library. To build it, make sure to configure with the
- @-fexample@ flag.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">echo</remote-id>
+ <remote-id type="github">RyanGlScott/echo</remote-id>
+ </upstream>
</pkgmetadata>