summaryrefslogtreecommitdiff
path: root/dev-haskell/drift/drift-2.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/drift/drift-2.4.2.ebuild')
-rw-r--r--dev-haskell/drift/drift-2.4.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/drift/drift-2.4.2.ebuild b/dev-haskell/drift/drift-2.4.2.ebuild
new file mode 100644
index 000000000000..af0147fc3568
--- /dev/null
+++ b/dev-haskell/drift/drift-2.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.5.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Program to derive type class instances"
+HOMEPAGE="http://repetae.net/computer/haskell/DrIFT/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/old-time:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}