summaryrefslogtreecommitdiff
path: root/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dataenc/dataenc-0.14.0.7.ebuild')
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild
new file mode 100644
index 000000000000..6a61df78e57d
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.5:2=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ dev-haskell/test-framework-th:=[profile?] )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 3.0.0 && < 4.8' 'base >= 3.0.0' \
+ 'QuickCheck ==2.5.*' 'QuickCheck >=2.5' \
+ 'executable tests' 'executable dataenc-tests'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test tests)
+}