summaryrefslogtreecommitdiff
path: root/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dataenc/dataenc-0.14.0.5.ebuild')
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild
new file mode 100644
index 000000000000..1086d71e0214
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'array >= 0.1.0 && < 0.5' 'array >= 0.1.0 && < 0.6' \
+ 'base >= 3.0.0 && < 4.7' 'base >= 3.0.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-tests
+}