summaryrefslogtreecommitdiff
path: root/dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild')
-rw-r--r--dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild b/dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild
new file mode 100644
index 000000000000..322e73d7a889
--- /dev/null
+++ b/dev-haskell/data-array-byte/data-array-byte-0.1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compatibility layer for Data.Array.Byte"
+HOMEPAGE="https://github.com/Bodigrim/data-array-byte"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/quickcheck-classes-base-0.6 <dev-haskell/quickcheck-classes-base-0.7
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}