summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild')
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
new file mode 100644
index 000000000000..661de1637479
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cipher-aes-0.2.3:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ >=dev-haskell/cipher-blowfish-0.0:=[profile?] <dev-haskell/cipher-blowfish-0.1:=[profile?]
+ >=dev-haskell/cipher-camellia-0.0:=[profile?] <dev-haskell/cipher-camellia-0.1:=[profile?]
+ >=dev-haskell/cipher-des-0.0:=[profile?] <dev-haskell/cipher-des-0.1:=[profile?]
+ >=dev-haskell/cipher-rc4-0.1.3:=[profile?] <dev-haskell/cipher-rc4-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"