summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-api
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/crypto-api')
-rw-r--r--dev-haskell/crypto-api/Manifest5
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild31
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.13.2.ebuild33
-rw-r--r--dev-haskell/crypto-api/metadata.xml25
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-haskell/crypto-api/Manifest b/dev-haskell/crypto-api/Manifest
new file mode 100644
index 000000000000..dd911c04afa3
--- /dev/null
+++ b/dev-haskell/crypto-api/Manifest
@@ -0,0 +1,5 @@
+DIST crypto-api-0.12.2.2.tar.gz 45271 BLAKE2B e5290eabe5ee7c70c3fc7e957853477a343716192cbbc39a30cc8b7515e12f3fcfa904cc01ef4262663ead64dd5c2fe34097576cd2e9aa89fac2f888651464e6 SHA512 340aefd9f8b24d99866fce26bd3eaba8484be6e15648a2ff1a0a051f8974514a50f809f8d2539c7fe747dbe1b6946a1ecfa8a2966548391e71b498d19e79cc86
+DIST crypto-api-0.13.2.tar.gz 47877 BLAKE2B e9a10cdc7ab66ce4155856feb4ce4df93e7f49785fb9571f326377f9b5faf5a939aa625d9ad75bf31835b2a764bacb2a2a762b4d25c20faaaeedcfb205d20cb8 SHA512 2803862a714c3f448aa63469171fc68835ea9648a94d69ec76a32d20c1ed480aa3ecacedc3bf1e674797430c5d2966ceea4a83e38e827a68d2fab78fb4c8567c
+EBUILD crypto-api-0.12.2.2.ebuild 806 BLAKE2B a01a6f1492964d40c37b2b9147a41fcf87cdf401029d633ec2ead78b0509b62a30309d340988ca22abaeee21a5880e17f0f0fd6d798c56c9918354d8956a8f75 SHA512 a3b361c62abcf49874d9e8309bf5cef1ac87afa835a36d0e7d889581cda0aa47e665699e1ecbe2e7a295448713a83a30acf5b3cf9ace70bcb22dcce160ea6779
+EBUILD crypto-api-0.13.2.ebuild 813 BLAKE2B 9024329fd5eef2705bf10def6ed96b72046ec1d57ecb5a8f522f8fd46530459f2f837148841d1e1215dec23b4792154a5ae83880c540055423f67b7c987e9c86 SHA512 ad984ce7bbde4d7fb4842db1ef15284c94080edcf5e05d17afe2a5b9f77077294c7910b05ae475abbd8ecea260ddd2dbc642ee163cfcf0171286de7d76a84e98
+MISC metadata.xml 935 BLAKE2B 720707a1375a75abd923fad0446e9b1c72b4655dd816eff0b380b2bcf0b770cb2dd43c053a28f22b2fef715b015f12fc7b9ed0219d9d4bd413a86d9477b0a00b SHA512 6851ee1e8aa4bb9bb1fb396c75ddfd09cae5116ee03b05ed5ceb23ad30ae2ae10c457753de3050f4c157a4d4b6d1e95ef1dd5338b20458a80476b2790568d001
diff --git a/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
new file mode 100644
index 000000000000..bb6cd4b5bc36
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}
diff --git a/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild b/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild
new file mode 100644
index 000000000000..a38648c23edb
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}
diff --git a/dev-haskell/crypto-api/metadata.xml b/dev-haskell/crypto-api/metadata.xml
new file mode 100644
index 000000000000..92b13075a714
--- /dev/null
+++ b/dev-haskell/crypto-api/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A generic interface for cryptographic operations (hashes, ciphers, randomness).
+ Maintainers of hash and cipher implementations are
+ encouraged to add instances for the classes defined
+ in Crypto.Classes. Crypto users are similarly
+ encouraged to use the interfaces defined in the Classes
+ module.
+ Any concepts or functions of general use to more than
+ one cryptographic algorithm (ex: padding) is within
+ scope of this package.
+ </longdescription>
+ <use>
+ <flag name="all_cpolys">Build all the CMAC polynomes up to 10000 bits instead of just the usual ones</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">TomMD/crypto-api</remote-id>
+ </upstream>
+</pkgmetadata>