summaryrefslogtreecommitdiff
path: root/dev-haskell/concurrent-extra
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/concurrent-extra')
-rw-r--r--dev-haskell/concurrent-extra/Manifest3
-rw-r--r--dev-haskell/concurrent-extra/concurrent-extra-0.7.0.12.ebuild33
-rw-r--r--dev-haskell/concurrent-extra/metadata.xml38
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-haskell/concurrent-extra/Manifest b/dev-haskell/concurrent-extra/Manifest
deleted file mode 100644
index 7f970533cb46..000000000000
--- a/dev-haskell/concurrent-extra/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST concurrent-extra-0.7.0.12.tar.gz 15844 BLAKE2B 1220bdaa6bbc364c4a2e12adc3dd953459d8dcbc251db776e906facc2b80aa4239d35cc29c19fea767e27c0a451b5b29c3010f8a97943db6e73801980888b7c7 SHA512 b02bfa8473faeba15bf26f4c243190dee7820dd961bc86cb7cd1eb856451a9351899eea59b3668f0b811c95f828cd8c36744dfa03144ca0a949e3b663ae84ad2
-EBUILD concurrent-extra-0.7.0.12.ebuild 856 BLAKE2B 7a1f1c2a2437cbadc6ebe0e047ca08735ce9f942952c4b7eca3580b743243876eb2a60f4c2c7ea172f628cb9b40fe5026e8b13503648454792e88986dc08b9dd SHA512 386135cec06a86b3dcdd2b4a30d928bd12e103f6fedba20306bb2f76f9624da8a62a339d586a0abe75d047b6ce1f0a3a1fa7e06a70ef551fa06499fbc244bc81
-MISC metadata.xml 1336 BLAKE2B ed33d9fe65403358a786993cfc578ab843f9e50ee3e83f9715d28baf83a66c02f839042f6bbe44a42d6d8e9c0dcef727d821de7353b18945f2384b5aca517e84 SHA512 7a0b5bb3ecf63991d2e201c56580a25d50749df75933db0322c974c09f8d7ab55166e1322ed4277791fb94668fcd81dbabca4bee342ddfa2917929415248f8ef
diff --git a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.12.ebuild b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.12.ebuild
deleted file mode 100644
index c8301f605c70..000000000000
--- a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.12.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.5.5.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Extra concurrency primitives"
-HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test #stresstest fails, all others pass
-
-RDEPEND=">=dev-haskell/stm-2.1.2.1:=[profile?]
- >=dev-haskell/unbounded-delays-0.1:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/async-2.0
- >=dev-haskell/hunit-1.2.2
- >=dev-haskell/random-1.0
- >=dev-haskell/test-framework-0.2.4
- >=dev-haskell/test-framework-hunit-0.2.4 )
-"
diff --git a/dev-haskell/concurrent-extra/metadata.xml b/dev-haskell/concurrent-extra/metadata.xml
deleted file mode 100644
index 34510840b00c..000000000000
--- a/dev-haskell/concurrent-extra/metadata.xml
+++ /dev/null
@@ -1,38 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- The @concurrent-extra@ package offers among other things the
- following selection of synchronisation primitives:
-
- * @Broadcast@: Wake multiple threads by broadcasting a value.
-
- * @Event@: Wake multiple threads by signalling an event.
-
- * @Lock@: Enforce exclusive access to a resource. Also known as a
- binary semaphore or mutex. The package additionally provides an
- alternative that works in the @STM@ monad.
-
- * @RLock@: A lock which can be acquired multiple times by the same
- thread. Also known as a reentrant mutex.
-
- * @ReadWriteLock@: Multiple-reader, single-writer locks. Used to
- protect shared resources which may be concurrently read, but only
- sequentially written.
-
- * @ReadWriteVar@: Concurrent read, sequential write variables.
-
- Please consult the API documentation of the individual modules for
- more detailed information.
-
- This package was inspired by the concurrency libraries of Java and
- Python.
- </longdescription>
- <upstream>
- <remote-id type="github">basvandijk/concurrent-extra</remote-id>
- </upstream>
-</pkgmetadata>