summaryrefslogtreecommitdiff
path: root/dev-haskell/cmark
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cmark')
-rw-r--r--dev-haskell/cmark/Manifest3
-rw-r--r--dev-haskell/cmark/cmark-0.6.ebuild34
-rw-r--r--dev-haskell/cmark/metadata.xml90
3 files changed, 0 insertions, 127 deletions
diff --git a/dev-haskell/cmark/Manifest b/dev-haskell/cmark/Manifest
deleted file mode 100644
index 2539a5c71882..000000000000
--- a/dev-haskell/cmark/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST cmark-0.6.tar.gz 169132 BLAKE2B d6c72aa17216f89e90a269d2fcd6639f25ac2e9aa02a0799108a85247b5ccb5211ee02dc078cdbccfbd6295705799d5b49e2af70d50cd6a791fbf4ddcea70a01 SHA512 35d2851bb1d3305000527cfce81253c9492a3e3205e73418fe42fcc9f8e5f8e396a7ecf81ad4a003a2dd4a571c4f7d051bc6812c07a5c79dc30eac1d45fca4f5
-EBUILD cmark-0.6.ebuild 904 BLAKE2B 060cc1a7c9909a98bd7c11611d9b0115f4e79d6fff997adfe99c5a101c6287c7df33021bd9c68b46e5490ed19f0a947c496b77678352bd79eac8bd2cff8083b0 SHA512 b5e30412503a9ad8001549dd241a7f174f61d492ea741fa4a726a11156361f9fa4a4b45af24a138152f5dfb8b38b836208b9d9b134a3332ed3008287bcea4b60
-MISC metadata.xml 3530 BLAKE2B 9e63a7eb6f84918152e90bd37fd42fe8d67a616a8344b91a9fe6cba182801f5c8b1c0ee6d30d8f1e6c9dca8dca5695300a40c805d9159aac03ff94c39df305b5 SHA512 fd3f332f41df9ac1659fae705adcf3983182c1ac9f95211962f4505a0c272d1f9545ea88ff67af8408a375ace0dacb9aadc3ded1eaf32881dc3cfd10e608cb15
diff --git a/dev-haskell/cmark/cmark-0.6.ebuild b/dev-haskell/cmark/cmark-0.6.ebuild
deleted file mode 100644
index ebd870a5758e..000000000000
--- a/dev-haskell/cmark/cmark-0.6.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: pkgconfig:system-cmark
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
-HOMEPAGE="https://github.com/jgm/cmark-hs"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="system-cmark"
-
-RDEPEND=">=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- system-cmark? ( app-text/cmark )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.14
- test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7 )
- system-cmark? ( virtual/pkgconfig )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag system-cmark pkgconfig)
-}
diff --git a/dev-haskell/cmark/metadata.xml b/dev-haskell/cmark/metadata.xml
deleted file mode 100644
index 0331282b8416..000000000000
--- a/dev-haskell/cmark/metadata.xml
+++ /dev/null
@@ -1,90 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <use>
- <flag name="system-cmark">use <pkg>app-text/cmark</pkg> instead of bundled copy</flag>
- </use>
- <longdescription>
- This package provides Haskell bindings for
- &lt;https://github.com/jgm/cmark libcmark&gt;, the reference
- parser for &lt;http://commonmark.org CommonMark&gt;, a fully
- specified variant of Markdown. It includes sources for
- libcmark (0.19.0) and does not require prior installation of the
- C library.
-
- cmark provides the following advantages over existing
- Markdown libraries for Haskell:
-
- - Speed: Conversion speed is on par with the
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;
- library. We were unable to measure precisely
- against
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;,
- which raised a malloc error when compiled into our
- benchmark suite. Relative to other implementations:
- cmark was 82 times faster than
- &lt;https://hackage.haskell.org/package/cheapskate cheapskate&gt;,
- 59 times faster than
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;,
- 105 times faster than
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;,
- and 2.8 times faster than
- &lt;https://hackage.haskell.org/package/discount discount&gt;.
-
- - Memory footprint: Memory footprint is on par with
- &lt;https://hackage.haskell.org/package/sundown sundown&gt;.
- On one sample, the library uses a fourth the memory that
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;
- uses, and less than a tenth the memory that
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;
- uses.
-
- - Robustness: cmark can handle whatever is thrown
- at it, without the exponential blowups in parsing
- time one can sometimes get with other libraries.
- (The input @bench\/full-sample.md@, for example,
- causes both
- &lt;https://hackage.haskell.org/package/pandoc pandoc&gt;
- and
- &lt;https://hackage.haskell.org/package/markdown markdown&gt;
- to grind to a halt.)
-
- - Accuracy: cmark passes the CommonMark spec\'s
- suite of over 500 conformance tests.
-
- - Standardization: Since there is a spec and a
- comprehensive suite of tests, we can have a high
- degree of confidence that any two CommonMark
- implementations will behave the same. Thus, for
- example, one could use this library for server-side
- rendering and
- &lt;https://github.com/jgm/commonmark.js commonmark.js&gt;
- for client-side previewing.
-
- - Ease of installation: cmark is portable and has
- minimal dependencies.
-
- cmark does not provide Haskell versions of the whole
- &lt;https://github.com/jgm/cmark libcmark&gt; API, which is
- built around mutable @cmark_node@ objects. Instead, it
- provides functions for converting CommonMark to HTML
- (and other formats), and a function for converting
- CommonMark to a @Node@ tree that can be processed
- further using Haskell.
-
- A note on security: This library does not attempt
- to sanitize HTML output. We recommend using
- &lt;https://hackage.haskell.org/package/xss-sanitize xss-sanitize&gt;
- to filter the output.
-
- A note on stability: There is a good chance the API
- will change significantly after this early release.
- </longdescription>
- <upstream>
- <remote-id type="github">jgm/commonmark-hs</remote-id>
- </upstream>
-</pkgmetadata>