summaryrefslogtreecommitdiff
path: root/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild')
-rw-r--r--dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild
new file mode 100644
index 000000000000..3899d491da97
--- /dev/null
+++ b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+#hackport: flags: -test,-halvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="AES and common modes using AES-NI when available"
+HOMEPAGE="https://github.com/TomMD/cipher-aes128"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ >=dev-haskell/crypto-api-0.13:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.10 && < 3.1' 'Cabal >= 1.10'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-halvm \
+ --flag=-test
+}