summaryrefslogtreecommitdiff
path: root/dev-haskell/chell/chell-0.4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/chell/chell-0.4.0.1.ebuild')
-rw-r--r--dev-haskell/chell/chell-0.4.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/chell/chell-0.4.0.1.ebuild b/dev-haskell/chell/chell-0.4.0.1.ebuild
new file mode 100644
index 000000000000..a89b0baa6803
--- /dev/null
+++ b/dev-haskell/chell/chell-0.4.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple and intuitive library for automated testing"
+HOMEPAGE="https://john-millikin.com/software/chell/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="+color-output"
+
+RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profile?]
+ >=dev-haskell/patience-0.1:=[profile?] <dev-haskell/patience-0.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ color-output? ( >=dev-haskell/ansi-terminal-0.5:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag color-output color-output)
+}