summaryrefslogtreecommitdiff
path: root/dev-haskell/base-orphans
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/base-orphans')
-rw-r--r--dev-haskell/base-orphans/Manifest4
-rw-r--r--dev-haskell/base-orphans/base-orphans-0.9.0.ebuild35
-rw-r--r--dev-haskell/base-orphans/metadata.xml8
3 files changed, 40 insertions, 7 deletions
diff --git a/dev-haskell/base-orphans/Manifest b/dev-haskell/base-orphans/Manifest
index a7c0db00932e..0165e573f6e3 100644
--- a/dev-haskell/base-orphans/Manifest
+++ b/dev-haskell/base-orphans/Manifest
@@ -1,3 +1,5 @@
DIST base-orphans-0.8.6.tar.gz 24255 BLAKE2B 8e8106cbdb58956ef6fc7c133e5a5c5537af8fa1ab56545a533f7c061361583b3921e77fdae2277a39cbc505a7e108fb672942528fe752fd7ef0506a4821547b SHA512 53cda663ee88e2ea53cf6b6d07b625a8343a6a26474bff9fa09554ee094e50429239615a892460fd676e9c3f80cbda0ad824052d785694fdbf1f2a90fa1e29ff
+DIST base-orphans-0.9.0.tar.gz 26025 BLAKE2B f5c5f6266b3f9ab746d76deae58f304827dea6f32dc95474c21314ee7dc3a7836428bc967e0e2ca2e19c39e063e1116ea4db1932f4d35e409a598d44991844e1 SHA512 63700bbd7f59ce598bd855de9e708559245bbac438d1585e5bdec3d0671d4940da3a25684abe727d88353c886eff5913da1fbbe98eada8f2325b20f1f7ffcf55
EBUILD base-orphans-0.8.6.ebuild 736 BLAKE2B 98f7886713953ef652a258a13129465b533c6126e8a4f261da566cd8859c1dd8b888625bf8b45164a70cf5d78b98bac01766b7d94e98a095eba8ed1bfef47ce5 SHA512 c8451a3e41cc7660de3051ba7b148ecec986938083d3280377fd7029371f7a0e419cf74dc21d14947828c1ae2af3bfc8e3f055606a034575b217a0e5299674dd
-MISC metadata.xml 807 BLAKE2B 38c0b75bcf2ed3539cddb1598182b6f6a00c3f73a8d9e42cb264b3f850764e3f13877b244f501b9d46ad4cc9c4616437f82f59b61a6a165f05c6d054b072f901 SHA512 9dde1cf788f1cad0f1bf33c1320f64f15cedc01b1ce7b1b4f99c963659555a2c3c77eac0f484fb9e258473d7ae9584597f62115b7f882d7bc9877af7457174e8
+EBUILD base-orphans-0.9.0.ebuild 905 BLAKE2B baa86ea5e3c62c5e32b1c91b37cc37bbf3fc582727b5c6ac09b7fb3156f2ab18fc52385c30ce3536c2022d6ca02194b9659882f149de961bfe624cb57471acb6 SHA512 883b6d3ec0913b4ff2df181fc976d5e51a91e3dcb03ff1f788a3790b38722486b9cff20151da29f55ed3a4d5e91b073d7c2209e62e86f03ed64bfd7256e4a502
+MISC metadata.xml 395 BLAKE2B a94006776c1430cdb13fee1c9365079d9d695240116e6466845243d84046d484e0f1242aa9887443cb7c39059aa18602eaa0fabd81b6d1d72c105829d211f226 SHA512 ce7367f5e9dd389addeb25821730eeaf2bc35277069b90b99c95ae3b14819bd4cdc10dc487827c71d7883464ccbbabd003d288a47f50a0821df34bbac018986d
diff --git a/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild b/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild
new file mode 100644
index 000000000000..b9b1124f43f6
--- /dev/null
+++ b/dev-haskell/base-orphans/base-orphans-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Backwards-compatible orphan instances for base"
+HOMEPAGE="https://github.com/haskell-compat/base-orphans#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/quickcheck
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}
diff --git a/dev-haskell/base-orphans/metadata.xml b/dev-haskell/base-orphans/metadata.xml
index b75119e4482f..9b4ac4f22a89 100644
--- a/dev-haskell/base-orphans/metadata.xml
+++ b/dev-haskell/base-orphans/metadata.xml
@@ -5,12 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @base-orphans@ defines orphan instances that mimic instances available in later versions of @base@ to a wider (older) range of compilers. @base-orphans@ does not export anything except the orphan instances themselves and complements @&lt;http://hackage.haskell.org/package/base-compat base-compat&gt;@.
-
- See the README for what instances are covered: &lt;https://github.com/haskell-compat/base-orphans#readme&gt;
- </longdescription>
<upstream>
- <remote-id type="github">haskell-compat/base-orphans#readme</remote-id>
+ <remote-id type="hackage">base-orphans</remote-id>
+ <remote-id type="github">haskell-compat/base-orphans</remote-id>
</upstream>
</pkgmetadata>