summaryrefslogtreecommitdiff
path: root/dev-go/toml/toml-0.2.0_p20160716.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/toml/toml-0.2.0_p20160716.ebuild')
-rw-r--r--dev-go/toml/toml-0.2.0_p20160716.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-go/toml/toml-0.2.0_p20160716.ebuild b/dev-go/toml/toml-0.2.0_p20160716.ebuild
new file mode 100644
index 000000000000..219ac2df52af
--- /dev/null
+++ b/dev-go/toml/toml-0.2.0_p20160716.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/BurntSushi/toml"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="99064174e013895bbd9b025c31100bd1d9b590ca"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="TOML parser for Golang with reflection"
+HOMEPAGE="https://github.com/BurntSushi/toml"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -o "bin/tomlv" ./cmd/tomlv || die
+}
+
+src_install() {
+ dodoc README.md
+ dobin bin/tomlv
+}