summaryrefslogtreecommitdiff
path: root/dev-go/gox/gox-0_pre20160725.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gox/gox-0_pre20160725.ebuild')
-rw-r--r--dev-go/gox/gox-0_pre20160725.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-go/gox/gox-0_pre20160725.ebuild b/dev-go/gox/gox-0_pre20160725.ebuild
new file mode 100644
index 000000000000..f7145c418b0f
--- /dev/null
+++ b/dev-go/gox/gox-0_pre20160725.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_VENDOR=( "github.com/mitchellh/iochan 87b45ffd0e9581375c491fef3d32130bb15c5bd7" )
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/mitchellh/gox"
+EGIT_COMMIT="c9740af9c6574448fd48eb30a71f964014c7a837"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A dead simple, no frills Go cross compile tool"
+HOMEPAGE="https://github.com/mitchellh/gox"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MPL-2.0"
+SLOT="0/${PVR}"
+IUSE=""
+
+RESTRICT="test"
+
+src_install() {
+ dobin ${PN}
+ dodoc src/${EGO_PN}/README.md
+}